Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 09:30 NZDT
Scheduled
On Wednesday, 26 November, we will be completing the UPS upgrade at our Te Rapa facility. Due to the age and configuration of the existing ABB units, this work carries a low to medium level of risk. We are taking every possible step to avoid any interruption to service, and while none is anticipated, the risk is elevated during the change.
A full transition plan has been approved by all partners, and the site will operate on generator supply during parts of the work. Customers are not required to power down equipment, but you may shift workloads if you prefer.
We ask that customers avoid visiting the site on the day due to high activity levels and limited space.
This upgrade replaces end of life UPS hardware and supports ongoing reliability and sustainability of supply.
Posted Nov 20, 2025 - 09:42 NZDT
This scheduled maintenance affected: Hamilton Data Center (UPS and Power).